Road Glide banner

1 - 20 of 21 Posts

·
Registered
Joined
·
1,679 Posts
Discussion Starter #1 (Edited)
Well I finally got the new tire mounted and with that the TPMS. Bike is a 2019 Special. Nothing needed but the sensors and the Digital Technician to activate them in the BCM and the readout in the radio, and the hand held unit to tell the seniors which one was witch.
Sensor and part number.
416349


Before TPMS
416352


After TPMS added

416353
 

·
Registered
Joined
·
53 Posts
What diameter are the stems, @craigffb? Or better question, what wheels are you running on your bike?

You had no need for spacers/adapters for the wheels/sensor combo you're running?
 

·
Registered
Joined
·
1,679 Posts
Discussion Starter #5
What diameter are the stems, @craigffb? Or better question, what wheels are you running on your bike?

You had no need for spacers/adapters for the wheels/sensor combo you're running?
Stock 2019 Road Glide Special Turbine. Just the sensor and have them turned on. That’s it.
 

·
Registered
Joined
·
1,679 Posts
Discussion Starter #11
Will they fit the newer ultras?
I have a 2018 Road Glide Ultra.
I don’t know if they will fit the ultra rim without a different gasket. But they will work.
I know they fit the Turbine and the Enforcer rims without anything else.
Sorry. If I ever come across the correct answer I’ll post it. You could get the spacer gasket from FOBO and the would work.
 

·
Registered
Joined
·
386 Posts
I did this to my 17 rgu. I bought the cvo sensors and put them in at a tote change. Mine does not show on the odometer just on the radio/other info page. Like push the right thumb button to get to temp and then scroll right one time to see tire pressure.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,679 Posts
Discussion Starter #13
@ia15rgs do you mind adding a pic of your rim to you post? Might help someone out.
And yes no display in the odometer because out stock gauges don’t have that function. If you added the P&A gauges it WOULD show in the cluster.
 

·
Registered
Joined
·
53 Posts
I did this to my 17 rgu. I bought the cvo sensors and put them in at a tote change. Mine does not show on the odometer just on the radio/other info page. Like push the right thumb button to get to temp and then scroll right one time to see tire pressure.


Sent from my iPhone using Tapatalk
@ia15rgs, did you use the FOBO adapter to install the sensors into the stock wheels, or are you running different wheels that have 8.3mm valve stem holes? My '17 Ultra has the Impeller wheels- I'm assuming (though haven't measured the base of the valve stem) that they're 11.3mm stems for the stock wheels.

Did your dealer have any problems with doing the steps: meaning try to tell you that it can't be done, or anything like that? Or did they do the install of the sensors and activate everything as part of your tire change? Or did you have the activation done by a shop with Diag4Bike?
 

·
Registered
Joined
·
386 Posts
I did them when I worked at taboo H-D in Louisiana. Stock 17 ultra rim. Cvo sensors. Digital tech flash. Out the door I went


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,132 Posts
Accomplished this as well over the winter after checking out some threads. Using the same CVO part numbers you posted with stock Impeller wheels. Easy peasy to do. Just make sure the dealer enables it correctly like you have shown in the infotainment display and not in the odometer window. Or you can probably do both if you want it that way. Awesome upgrade!!!
 

·
Registered
Joined
·
1,679 Posts
Discussion Starter #18
Accomplished this as well over the winter after checking out some threads. Using the same CVO part numbers you posted with stock Impeller wheels. Easy peasy to do. Just make sure the dealer enables it correctly like you have shown in the infotainment display and not in the odometer window. Or you can probably do both if you want it that way. Awesome upgrade!!!
It will ONLY show in the odometer window if you have CVO gauges, P&A gauges, or 2020 gauges. The gauges on our bikes don’t have the ability to display the TPMS information.
 

·
Registered
Joined
·
2,132 Posts
I have CVO gauges on my RGU displaying the PSI but wanted the display on my GTS. I thought the gauge display was meant for models without the infotainment like a Road King or Freewheeler regardless of what type of gauges they have. I think someone checked the wrong feature possibly when they used the DT to activate mine.
 

·
Registered
Joined
·
1,679 Posts
Discussion Starter #20
I have CVO gauges on my RGU displaying the PSI but wanted the display on my GTS. I thought the gauge display was meant for models without the infotainment like a Road King or Freewheeler regardless of what type of gauges they have. I think someone checked the wrong feature possibly when they used the DT to activate mine.
The way I understand it is if you have gauges cable of displaying it it will display on both. Like the warning Like in you gauges (!) should pop up as well. That’s just the way I understood it, but I could be wrong.
 
1 - 20 of 21 Posts
Top