Road Glide banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8,225 Posts
Cool looking, but I agree with the overpricing. I guess if people will pay it,.. why drop the price eh.
 

·
Registered
Joined
·
1,215 Posts
Not the same brand but Chainsaw turned me on to a guy who makes custom bars. Sort of old school with a modern twist. No problems with special requests. I'm in the process of getting a set made for my 07 RG. Looking at the bikes you have I figured you would like his stuff. Check out both sites.
http://rockschops.blogspot.com/
http://www.rockschops.com/custombars.html
 

·
Registered
Joined
·
1,215 Posts
I'm not saying that the bars you were looking at are bad or anything but if you can save $200 and give Rocks some business all is good.
 

·
Registered
Joined
·
8,225 Posts
Rock is a good guy, and makes quality sets of bars. He can make anything you want, just give him a call.
 

·
Registered
Joined
·
5,189 Posts
Trouble shooting assist request

Well I got the bars on (Yaffee Monkey Bars), but I have run into an issue since the install. Actually two issues, but one I don't think is caused by the bars.
When I buttoned everything up last night and went for a test ride, I am having throttle issues. It runs as though the rev limiter is kicking in at about
3K RPMs. It's as though I am pulling a trailer and response is completly flat. It will go past 3K but seems to drag getting there. Now with the faring off, I have a lone cannon plug (two prong black and white wires) that I can't account for. All lights work, signals, brakes, dash, etc... It did throw a code, and the engine light is on constantly, which I believe is caused by it having thrown a code... Any suggestions on troubleshooting????
The second thing that came up is a NASTY wabble in the front end. I raised my hands up off the bars, and damn, there is a crazy wabble in my front end. Had I been running at highway speed, I don't know that I could have gotten the bars back into my hands. I just got the bike back from a 1K service, and have only ridden it about 20 miles, but I have never experienced anything like that before. I don't think it is related to new bars, at least I have never seen or heard anyone mention it before. I know there was a thread about this a few weeks ago, but time is of the essence this morning, as I am at work, and hopefully going back to work on these issues today.
Any help would be appreciated.

Rowdy
 
1 - 11 of 11 Posts
Top