Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just had my cams done at the stealership and here's what's going on:

at 4500 rpm she starts to shake up to 5000 it gets worse. I did the SE 585 cams, SE valve springs and lifters, all new. Used the SE pro street tuner.

Your feedback is welcomed. I know I am going to have the dealership solve this issue.

Thanks,
Detroit Tony
 

·
Registered
Joined
·
4,861 Posts
Hi Tony, welcome from Mass.

Right back to the dealer, you paid for a service to be perfomed. They should deliver your bike running correctly.
 

·
Registered
Joined
·
1,243 Posts
Did they do a full dyno tune, or just a download? Bad tune can cause symptoms like you describe. I’d have that checked before tearing things apart first. Next thing would be to check and ensure that the cams are timed correctly and they don’t have a tooth off plus put a micrometer on the crank to check runout.

Good luck.
 

·
Registered
Joined
·
8,856 Posts
What year bike ? If it's a Twin cam , dump the Street turner. You'll never get a great tune staying with in epa compliance.
 
  • Like
Reactions: RFG7680 and Swomack

·
Registered
Joined
·
16 Posts
What year bike ? If it's a Twin cam , dump the Street turner. You'll never get a great tune staying with in epa compliance.
Hey Gary, I just did a stage 3 on my 15 RGS w/585 cams and its making a lot of tapping noise. HD says its normal, I don`t know. It was dyno tunned w/ TTS tunner and it runs real good but that tapping is driving me nuts... any idea whats going on there.
 

·
Registered
Joined
·
8,856 Posts
Hey Gary, I just did a stage 3 on my 15 RGS w/585 cams and its making a lot of tapping noise. HD says its normal, I don`t know. It was dyno tunned w/ TTS tunner and it runs real good but that tapping is driving me nuts... any idea whats going on there.
[/QUOT

You need somebody that knows how to work with a tts tuner , tweak the tune.
 

·
Registered
Joined
·
1,829 Posts
Hey Gary, I just did a stage 3 on my 15 RGS w/585 cams and its making a lot of tapping noise. HD says its normal, I don`t know. It was dyno tunned w/ TTS tunner and it runs real good but that tapping is driving me nuts... any idea whats going on there.
There is a problem somewhere...Mine was making a tapping noise just before it let go.
 
1 - 7 of 7 Posts
Top