Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1
hi all,

my bike has a TTS and it was tuned well over a year ago. all is great but lately i have been noticing engine ping in 5th and 6th when i roll on it hard from 1/8-1/4 throttle. it is especially evident when i am going uphill under load. sounds like front cylinder.

does this sound like all they need to do is take a little timing out? do i need to go back to the original tuner to do this? or can any good tuner do that? does it need a full retune, or just a 10 minute software change?

this is my first time with TTS so that's why all the questions. thanks for the help

bike info: 103", 2012, 254E cams, fuel moto intake, fuel moto 2-1-2 head pipe, VH monster rounds
 

·
Registered
Joined
·
1,066 Posts
When you say lately do you mean in the last tank full of fuel. Maybe bad gas. Try a different supplier. What octane do you use. It's possible that you have a bit of carbon buildup. I have used sea foam in the fuel tank with great results.
 

·
Registered
Joined
·
1,756 Posts
I have the same problem. It only seems to happen then the bike is hot and its when going from cruising to WOT like during passing, etc in and around the 2k-3k RPM range.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #4
thought the same thing but i have ran lots of tanks through it and no change. i only use 91 octane. i'm thinking it was always there i just finally noticed it one day.


When you say lately do you mean in the last tank full of fuel. Maybe bad gas. Try a different supplier. What octane do you use. It's possible that you have a bit of carbon buildup. I have used sea foam in the fuel tank with great results.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #5
yep, that's where my ping is also. 2-3k in 5th or 6th then when i give 'er a good twist.

on a side note, what part of PA are you from? i grew up in carlisle, just south of harrisburg.

I have the same problem. It only seems to happen then the bike is hot and its when going from cruising to WOT like during passing, etc in and around the 2k-3k RPM range.
 

·
Registered
Joined
·
1,756 Posts
I'm actually in Chambersburg. I'm about 20mins south of Carlisle down I81.

And that's exactly how mine is also. Running a PC5 with an auto tune and my auto tune will not adjust it. I had a $50 run for A/F done last summer at a local bike night and it was running lean in that RPM range.

I too have also read about it being timing. I might have it redynoed this summer. I'll just by some Dragos 580 cams before I do that.
 

·
Registered
Joined
·
178 Posts
Pull a couple degrees of timing out at the RPM range between 50-70 MAP. best thing to do is do a data run with TTS hooked up and see exactly where ping occurs and then reduce timing.
 
1 - 7 of 7 Posts
Top