Road Glide banner

1 - 13 of 13 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
does anyone else does this... when coming to a stop the voltage drops from 14 to 11 to 12 volts....???
 

·
Administrator
Joined
·
10,504 Posts
nope shouldnt drop that low ...

dont know how much "error" is built into the gauge ..

lights dim ??

hard to start ??
 

·
Registered
Joined
·
102 Posts
Discussion Starter #3
I notice the light dim slowly and brightens back up when I give it throttle...
also I hear a loud Clunk when I restart the bike after riding for a couple of hours...
 

·
Registered
Joined
·
1,361 Posts
I notice the light dim slowly and brightens back up when I give it throttle...
also I hear a loud Clunk when I restart the bike after riding for a couple of hours...
Look on the bright side, excuse the pun, if the stator is going out you can replace the compensator with no labor cost!!
 

·
Registered
Joined
·
102 Posts
Discussion Starter #6
its a 2008...
 

·
Administrator
Joined
·
10,504 Posts
sounds like it is charging OK , check the battery connections , they must be tight ..

maybe something shorting out somewhere ??
 

·
Registered
Joined
·
1,521 Posts
Per the indy shop I go to, more stators seem to go bad during high ambient heat than other issues...and we're all experiencing that right now.

I'd double-check all your connections and if not found there, time to have the stator tested.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #9
well tested the battery reading at 12.6 to 12.8
starting the bike I got a reading from 13.9 to 14.3

the dimming was from the bike shaking... Had my wife stand in front of it to see if the light dim... nope

but going to have the shop to make dam sure on the battery... Its the original battery from 2007

wish me luck
 

·
Administrator
Joined
·
10,504 Posts
sounds like that battery is good .. shud read 12.7 , not running and 13.9-14.3 is right for the charging ..

Harley batteries last a good while , had some go six-7 years
 

·
Registered
Joined
·
102 Posts
Discussion Starter #11
could be a Bad dashboard Gauge... as long the Glide fires up....
 

·
Registered
Joined
·
6,625 Posts
The voltage drop is normal. The voltage should drop on a idle because the stator is not turning as fast. When the RPM's increase the voltage will return to normal. As long as the lights are bright and you have no starting issues that would make you think that the battery is bad then the stator is doing it's job. If the stator goes bad you won't be riding your bike for long because the bike won't start after you turn it off.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #13
Thanks for the heads up on that... so yours at stop drops to 12 volts and revs back up to 14 volts? again thanks for the input
 
1 - 13 of 13 Posts
Top