Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
On my last 3 rides, when I leave the house, within a mile or 2 the Check engine and Voltage lights come on..Volt gauge says less than 12 volts.. when I shut it off, wait 30 seconds or so and fire it back up, everything back to normal..I can shut it off at stops throughout the day and will be fine...
 

·
Registered
Joined
·
3,042 Posts
On my last 3 rides, when I leave the house, within a mile or 2 the Check engine and Voltage lights come on..Volt gauge says less than 12 volts.. when I shut it off, wait 30 seconds or so and fire it back up, everything back to normal..I can shut it off at stops throughout the day and will be fine...

2012 bikes had issues with their voltage regulators for awhile. I believe there was a recall covering the replacement if there was a problem.
Check with your dealer.
 

·
Registered
Joined
·
8,790 Posts
On my last 3 rides, when I leave the house, within a mile or 2 the Check engine and Voltage lights come on..Volt gauge says less than 12 volts.. when I shut it off, wait 30 seconds or so and fire it back up, everything back to normal..I can shut it off at stops throughout the day and will be fine...
Check to make sure all connections are clean & tight. If they're all good, it's probably the VR going bad.
 

·
Registered
Joined
·
951 Posts
I had the same thing happen on my 2012 RGU. Just before the Service Bulletin went out. Dealer took care of it under warranty with no hassles.

Good Luck with yours.
 
1 - 6 of 6 Posts
Top