Road Glide banner

1 - 4 of 4 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
So I was replacing a loose "Audio + -" button at my left grip. As I was pulling the plastic part trying to get it off of the metal holder it was mounted to, I pulled the entire switch out of position. It now just wiggles in and out and in a 360 degree circle. I can't push it back in its 'socket'. Can it be fixed or do i have to replace the lower housing? 2009 RG
 

·
Registered
Joined
·
9,108 Posts
So I was replacing a loose "Audio + -" button at my left grip. As I was pulling the plastic part trying to get it off of the metal holder it was mounted to, I pulled the entire switch out of position. It now just wiggles in and out and in a 360 degree circle. I can't push it back in its 'socket'. Can it be fixed or do i have to replace the lower housing? 2009 RG
I'm not a hundred % sure ,but iirc the switches are mounted in by a screw. You may of broke the plastic.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #3
The base is still in the metal housing. The toggle has been 'dislocated'. It looks like I'm going to have to replace the whole switch by cutting and resoldering the wires to keep from taking my bars off.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #4
I found out today that Harley makes a switch replacement kit for the older RGs. I hope this helps anybody else that has a similar problem.
424476
424477
 

Attachments

  • Like
Reactions: freezeland
1 - 4 of 4 Posts
Top