Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
I had a weird clutch experience yesterday. I was stuck in traffic and the bike was getting hot. Traffic was moving slow and lots of stop and go. I stopped at traffic light and felt the clutch cable shift on me. Shift was not possible and when I pressed the clutch in all the way, the bike still wanted to go forward in gear. I pulled over and adjusted the cable and it was OK from then on.

Any ideas why that happened?

I am going to swing by my mechanic this weekend to have him check out the bike, but it was weird. The cable adjustments were all tight.
 

·
Registered
Joined
·
273 Posts
200 hundred miles from home, in the rain, borderline lost, amongst 6' corn fields, and solo. I had recently installed a longer (knock off) clutch cable That I probably installed on the loose side also I don't know if there would be any stretch involved with a new longer knock off. Anyway the clutch wouldn't work and I could see it was in the lever, there is a clutch pin that can turn if the cable is loose making proper operation of the clutch difficult.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #4
This was a stock cable on a 2013 RGC with 9,000 miles on it. Cable was adjusted about a 1,000 miles ago.
 

·
Registered
Joined
·
198 Posts
While I was on vacation in Fla. temps in 90s I was stuck in traffic for about 30 min. As stop and go constant there was a point when my clutch did not want to fully disengage and it was a bear to find neutral . I had this happen to a friend of mine and thought he was crazy but for some reason as temps rise clutch doesn't want to disengage . I did no adjustment on mine and it was fine after we got moving again and temps dropped. Needless to say between this and oil pressure gage reading around 5lbs. I was extremely nervous. As of now I see no lasting effects from this
 

·
Registered
Joined
·
195 Posts
Discussion Starter #6
Thanks for the info
 
1 - 7 of 7 Posts
Top