Road Glide banner

1 - 3 of 3 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have attempted to install new bars and yes I tried to do it with the green TBW connector still attached. Which from my reading here is 95% of the time going to cause me problems. Of course with my luck I believe it has. I am getting 2 ECM error codes, P1510-Throttle actuator control limited performance and (one other code for TBW didn't bring it to work with me) and also U1040-Loss of ABS serial data. I also have the cruise control light alternating flashing red and green. I am going to try and pull the green connector back enough to cut green piece out and solder the connection without having to pull it all back through again. So my question is will removing that connector eliminate all the error codes? What does the flashing cruise light mean? Thanks for any input, I am really under the gun to get this complete.
 

·
Registered
Joined
·
516 Posts
Either cut and splice to remove the green connector and ensure that the wires are all in their correct position, or replace the entire TBW with the screaming eagle 32310-08 twist grip sensor. Also did you cut or dis-assemble the hand controls. If so make sure they are all pinned out properly....
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
I cut the hand controls and reverified that the colors matched. I will check the service manual to see what the cruise wires and verify that the soldered connection is ok.

How hard is it to run the CVO extended TBW line while the control wiring is already in place? Or do I need ot pull both and run them again?
 
1 - 3 of 3 Posts
Top