Road Glide banner

1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
I am installing an Alpine HD149BT head unit into my 2012 RGC. It had a boom audio upgrade and saddlebag speakers already installed when I bought it. I also have the biketronics BT1005 kit for hand control operations. I was hoping to try and still use the installed boom amp. I have the speakers already wired up but not sure what to do with the 2 yellow CAN wires. Currently no sound comes out of any speakers and I assume it is due to these CAN wires not being connected and sending their signal to the amp.

Any idea where the wires should be connected into the BT unit. I thought I would call them but they are not open till Monday.

Thanks.
 

·
Registered
Joined
·
1,344 Posts
Hopefully this helps...I just installed the 149BT in my 12 FLTRX using the Hawg Wired control kit and already had a ARC amp.

I just used RCA cables from the Alpine to the Amp. (your speakers should already be connected to the amp). I'm assuming the Boom Amp has RCA connectors on it.

You connect the wires from the Alpine wire loom to the BT handle bar kit based on the wiring diagram of the BT. I followed the wiring diagram on the Hawg Wired and it worked fine.

Then plug the OEM plug loom into the BT connection and you should be good.

Good Luck.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
The Boom amp doesn't have RCA's it just has paddle connectors on the end of the speaker wires.
 

·
Registered
Joined
·
1,344 Posts
Then you will have to use the hi level inputs. Run the speaker wires from the Alpine to the hi level in on the Boom amp. Hopefully it's labeled. I'm not familiar with the boom amps. Hopefully you have the paperwork at cam with it to assist with your install. Other wise I would call your local HD parts guy. Hopefully they are smart enough to assist or let you look at the paperwork that comes with the Boom amp
 
1 - 4 of 4 Posts
Top